Twitter Tools error: twitteroauth.php on line 19

I just updated to the most recent version of  Twitter Tools plugin and got this error:

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /wp-content/plugins/twitter-tools/twitteroauth.php on line 19

I did some digging and it turns out Twitter Tools 2.4 requires PHP5. So, that means you’ll have to check your server and see what your a running for PHP. Most control panels provide easy access to this infomation, if you can’t find it ask your host.

If you can’t upgrade PHP you’ll have to use an older versions of  Twitter Tools or use a different plugin.

5 Comments

  1. Andrea, it is a great post thanks for posting it!

  2. Wavy Hairstyles says:

    Inga said “what a load of crap!” just for the sake of irony, but I’ll refrain

  3. Its about time someone said this. Thanks for sharing your thoughts with the world, this is imoportant stuff to some of us.

  4. tg personals says:

    I also think the same as the commenter above.

  5. Thank you very much for that splendid article